External connectivity issues in eu-west1

Incident Report for Nebius

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 08:25 CET

Update

We experience external connectivity issues in eu-west1. Managed Kubernetes clusters creation in eu-west1 is also affected
Posted Nov 27, 2025 - 06:16 CET

Investigating

We are currently investigating this issue.
Posted Nov 27, 2025 - 05:23 CET
This incident affected: EU-WEST1 (Managed Service for Kubernetes®).