Increased response times for some objects, up to and including complete unavailability in eu-north1.

Incident Report for Nebius

Resolved

This incident has been resolved.
Posted Jun 27, 2025 - 16:30 CEST

Investigating

We are currently investigating this issue.
Posted Jun 27, 2025 - 16:15 CEST
This incident affected: Object Storage.