This incident has been resolved and all services and clusters should be operational now.
Posted Mar 11, 2026 - 00:49 UTC
Monitoring
Maintenance has been completed, and we do not expect any further power-related issues. We are now recovering services and closely monitoring system status.
Posted Mar 10, 2026 - 23:37 UTC
Update
We are continuing to investigate this issue.
Posted Mar 10, 2026 - 22:00 UTC
Update
We are continuing to investigate this issue.
Posted Mar 10, 2026 - 21:40 UTC
Investigating
We are currently experiencing another service disruption due to ongoing on-site maintenance. Our engineers are actively working to stabilize the affected clusters and maintain service throughout the maintenance period.
Posted Mar 10, 2026 - 20:39 UTC
Monitoring
We have identified failed switches and nodes. All major services were recovered, we are now collecting faulty instances and recovering them.
Posted Mar 10, 2026 - 18:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 18:12 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 15:59 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 10, 2026 - 15:54 UTC
Identified
During planned maintenance we experienced unexpected issues with power supply. We have identified the faulty circuits and already bringing nodes that are not part of planned maintenance back to work.
Posted Mar 10, 2026 - 15:47 UTC
This incident affected: US-CENTRAL1 (Compute Cloud, Object Storage, Virtual Private Cloud (Networking), Managed Service for Kubernetes®, Monitoring, Token Factory, Managed Service for MLflow, Managed Service for PostgreSQL®, Standalone Applications).