The root cause was identified, failed workloads restored.
Posted Feb 26, 2026 - 18:22 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2026 - 15:31 UTC
Investigating
We’re experiencing power issues in the eu-north1 region. Some resources (virtual machines, network disks and filestores) may be unavailable.
Posted Feb 26, 2026 - 14:40 UTC
This incident affected: EU-NORTH1 (Compute Cloud, Network Block Storage, Managed Service for Kubernetes®, Managed Service for MLflow, Managed Service for PostgreSQL®, Marketplace, Standalone Applications).