Services are partially unavailable for customers in eu-north2 region

Incident Report for Nebius

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 16:26 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 16:23 CET

Identified

We are currently experiencing a partial unavailability of our services, which may affect some of your workloads. Our team is actively investigating the issue and working towards a resolution. We will provide further updates as soon as more information becomes available.
Posted Oct 27, 2025 - 16:16 CET
This incident affected: EU-NORTH1 (Compute Cloud, Object Storage, Identity and Access Management, Billing).