Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 18, 2026 - 09:10 UTC
Scheduled
We will be performing a scheduled maintenance affecting the **uk-south1** cluster.
The maintenance will include physical works on the InfiniBand fabric uk-south1-a. Running Compute instances won't be affected, however InfiniBand connectivity may be temporarily unstable or intermittently unavailable within the maintenance window. No GPU firmware or host-level changes will be performed.
Our engineering teams will closely monitor the environment throughout the maintenance period to minimize impact and ensure network stability.
Please reach out to the Nebius Support team if you encounter any issues.
Posted Feb 18, 2026 - 09:09 UTC
This scheduled maintenance affected: UK-SOUTH1 (Compute Cloud).