VMs modifying operations, including start and stop, are experiencing increased latency and may take up to several minutes to complete.

Incident Report for Nebius

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 21:01 CET

Investigating

We are currently investigating this issue.
Posted Nov 18, 2025 - 20:15 CET
This incident affected: US-CENTRAL1 (Compute Cloud).