Connectivity issues are gone now. Intermittent failure is being investigated in the background with the uplink provider, while the Nebius Netowrking team continues to monitor the link closely.
Posted Jun 15, 2026 - 18:49 UTC
Investigating
We have noticed that there have been problems with the connection latency to external addresses in eu-north1.
Posted Jun 15, 2026 - 18:27 UTC
This incident affected: EU-NORTH1 (Virtual Private Cloud (Networking)).