The scheduled maintenance has been completed. All power supply works on the H200 nodes have been finished, and all nodes in the cluster have been fully restored.
Posted Mar 11, 2026 - 06:55 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 10, 2026 - 12:00 UTC
Scheduled
We will be performing an urgent power supply works on all H200 nodes in the cluster. This maintenance will address issues that may affect further workload stability.
All customer virtual machines will be stopped automatically by 13:00 CET on Tuesday, March 10.
The expected downtime is 15 hours.
We will provide updates on the maintenance progress via the status page and Support tickets. If you have any questions or experience any issues, please contact the Nebius Support team.
Posted Mar 10, 2026 - 10:47 UTC
This scheduled maintenance affected: US-CENTRAL1 (Compute Cloud).