Object Storage latency degradation for standard storage class

Incident Report for Nebius

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 00:45 CET

Investigating

We are currently experiencing Object Storage latency degradation. Our team is actively investigating the issue and working towards a resolution. We will provide further updates as soon as more information becomes available.
Posted Nov 11, 2025 - 00:00 CET
This incident affected: US-CENTRAL1 (Object Storage).