Consumption data is not updating for all users.

Incident Report for Nebius

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 09:00 CET

Investigating

We are currently investigating this issue.
Posted Jan 06, 2026 - 03:45 CET
This incident affected: EU-NORTH1 (Billing), EU-NORTH2 (Billing), EU-WEST1 (Billing), US-CENTRAL1 (Billing), ME-WEST1 (Billing), and UK-SOUTH1 (Billing).